WTI is NOT Affected by FREAK Vulnerability

Security Advisory CVE-2015-0204

The 'FREAK' attack is a new SSL/TLS vulnerability which allows attackers to intercept HTTPS connections between vulnerable clients and servers and force them to use weakened encryption. The attack is possible when a vulnerable browser connects to a server that accepts RSA_EXPORT cipher suites.

WTI products DO NOT accept RSA_EXPORT cipher suites and are NOT forced to use weakened encryption.

More information related to the FREAK Vulnerability can be found at https://freakattack.com

For questions related to the security of WTI products, please contact info@wti.com.



our promise to you
10 reasons
Important Update
FREAK Vulnerability

FREAK Vulnerability
  • WTI PRODUCTS
    NOT AFFECTED

LEARN MORE!
Featured Products

DSM-40-E Console Server

Dual GigE + Modem
SSH/HTTPS/SSL/TLS/FIPS

LEARN MORE!

  • “     I’m happy to report that, thanks to your fast response, I’ve been able to get our new WTI power reboot switch online without a hitch... ”         - Ben G. Tacoma
  • “     WTI products are hands down the most reliable gear we've got in our racks... ”         - Glen Baker
  • “     I’m happy to report that, thanks to your fast response, I’ve been able to get our new WTI power reboot switch online without a hitch... ”         - Ben G. Tacoma